Mijn website is naar een hogere PHPversie omgezet. Wat is daar de impact van?

Laatste aanpassing op: Di, 12 Feb, 2019 at 5:20 PM


PHP-versie 5.6

De nieuwe minimale versie.


We hebben bij een scan van onze systemen gezien dat een aantal websites nog gebruik maakt van een oude PHP-versie (lager dan 5.6).

Binnenkort wordt de server waar je website op staat vervangen voor een nieuwe. Die nieuwe server ondersteunt de oudere PHP-versies niet.

Dit betekent dat je site, in voorbereiding op deze migratie nu al voorzien is van PHP-versie 5.6.

Meestal is dit een kleine stap ten opzichte van je huidige PHP-versie en zal dit weinig gevolgen hebben. Zeker als je een CMS gebruikt wat up-to-date is. 


Maar het kan zijn dat je bewust voor gekozen hebt bepaalde PHP-scripts te draaien die voor een oudere PHP-versie gemaakt zijn en door PHP 5.6 niet ondersteund worden. Daarom adviseren we je om direct je site goed na te lopen en eventueel je scripts aan te passen. 

Deze PHP-versies 

Worden ondersteund op de nieuwe servers


5.6
7.0
7.1
7.2

Mocht je een site hebben die al van een van deze hogere PHP-versie gebruik maakt, dan nemen we die instelling mee over. Je PHP-versie blijft dan gelijk.

Mocht je nu op een versie zitten die lager is dan 5.6, dan zetten we die nu standaard op 5.6. 

Mocht je graag nu al (voor de migratie naar een nieuwe server) een hogere versie dan 5.6 willen, dan kun je ons dat per email laten weten, dan zetten we dat aan voor je. Mail dan naar support@alphamega.nl

Wat jij kunt doen na de migratie


Direct na de migratie sturen we je een email dat het overzetten gelukt is. Wat je dan het beste kunt doen is even je site doorlopen om te kijken of alles nog goed werkt. Check ook even of je email kunt versturen en ontvangen. 

Normaal gesproken moet dat vlekkeloos werken allemaal. Maar je weet maar nooit. Dus even website en email nalopen is een goed idee. 

Waarom dit nodig is


Voor de veiligheid van jouw site (en de sites van andere klanten op dezelfde server), worden er achter de schermen voortdurend automatische security-updates voor PHP-versies uitgebracht en doorgevoerd. 

Jouw website draait nu nog op een oude PHP-versie (lager dan 5.6). Dat is niet veilig, omdat daarvoor geen security-updates meer uitgebracht worden.

Voor versie 5.6 zijn er security updates geweest tot eind 2018. Nu niet meer. Het is dus aan te raden om je site klaar te maken voor 7.2. Die wordt nog jaren ondersteund met security updates. 

Hier kun je checken welke versies met security updates worden ondersteunt. 

In principe geldt: 

Hoe hoger de PHP-versie, hoe sneller en veiliger je site is. 


Mocht je vragen hebben, dan kun je mailen op support@alphamega.nl


Bellen kan natuurlijk ook: in Nederland 040-2085353 in België 011/547498 (maandag t/m vrijdag tussen 10.00 uur en 17.00 uur).

We willen je graag bedanken dat je je website bij Alphamega hebt ondergebracht en op deze manier willen wij laten zien dat we er voor je zijn en proactief voor je site zorgen. Doordat we nu je site overzetten op een nieuwe en snellere server, kun je er voorlopig weer tegenaan.






Vond je dit antwoord nuttig? Ja Nee

Kun je aangeven hoe we dit artikel kunnen verbeteren?
Excuses voor het Engelstalige formulier